LENIWA NIEDZIELA

Temat: ASA 5505 jako firewall przed serwerem
Z gory przepraszam za poziom mojego pytania ale dopiero zaczynam przygode z cisco...
Mam do dyspozycji ASA 5505 i chcialbym jakosc ja wykorzystac jako dodatkowy firewall w sieci internetowej, ktora obecnie wyglada tak:
modem DSL == serwer na linuxie == switch == hosty
ASA planuje wpiac miedzy DSL a serwer i w zwiazku tym mam pytanie czy mozna ja ustawic tak zeby dzialala transparentnie tzn. zeby dhcp, przycinaniem lacza, proxy itp. zajmowal sie tak jak dotychczas serwer? ASA ma pelnic tylko role zapory(przynajmniej takie mam zalozenie). Jesli tak sie da to bylbym wdzieczny za podpowiedz, ktore galezie w konfiguracji ASDM 5.2 trzeba ruszyc zeby to poszlo albo podanie linka do jakiegos manuala....

ponizej wrzucam jeszcze aktualny config:


ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password ZX.xxxxxxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.25.100 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 172.20.25.4 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd ZX.Dxxxxxxxxx encrypted
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns server-group DefaultDNS
 domain-name default.domain.invalid
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
username ciscoasa password oY/J/oLxWMC5Q46T encrypted privilege 15
http server enable
http 192.168.25.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.25.10 255.255.255.255 inside
telnet timeout 5
ssh 192.168.25.10 255.255.255.255 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.25.101-192.168.25.254 inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:96a64c4xxxxxxe4fbf11c64551c364
: end

Źródło: ccie.pl/viewtopic.php?t=8485